Author Topic: Load/Save not working - not duplicate post  (Read 781 times)

Solace015

  • Newbie
  • *
  • Posts: 3
    • View Profile
Load/Save not working - not duplicate post
« on: February 16, 2015, 08:35:51 PM »
Hey all,

I've searched these forums extensively and tried numerous suggestions posted with others who are/have had similar issues to no avail.

I got a netbook from a friend of mine and tried installing it no problems.

When I go to load it, I get a pop-up asking to load Microsoft Visual Basic 5.0 Control Cabinets File.  If I click yes, it says "Windows has found a problem with this file.  comdlg32.cab.  This file was blocked because it does not have a valid digital signature that verifies its publisher"

If I hit ok at this point or hit no on the previous post, the result is the same.  It will load up the program and all hotkeys seem to work but no pop-up dialogues work ie Load/Save etc.  I have used this installation file previously before and after formats on a system that this netbook is supposed to replace. 

It is version 1.3.5 [I know its an old version but I dont personally care for the newer versions with all the bells and whistles that I dont need - databases etc as I have a separate program I enter results into and it calculates points etc] - I like the simplicity of V1 
I have IE 9 installed
I have tried downloading comdlg32.cab myself and putting it in the TD program folder as well as the System32 folder [unarchived of course]
I tried restoring factory defaults on this machine not really knowing its history but that didnt resolve the issue either.

Thanks for your help in advance.

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5526
    • View Profile
Re: Load/Save not working - not duplicate post
« Reply #1 on: February 16, 2015, 10:18:51 PM »
Can't remember for sure, but I think it might have been Windows 7 Service Pack 1 when Microsoft broke something and no longer recognized their own signature.  So the previous version of the Common Dialog control (aka the VB 5.0 Control Cabinets file you referenced) no longer loads in Windows 7 SP1 and later.  Luckily there was a newer version of the control whose signature was still recognized.  I updated the TD with the newer version which fixed this in version 2.5.12 and version 3.0 (I think, might have been a beta version of 3.0).

Anyway, long story short: version 1.3.5 hasn't been supported in many years, and there's no fix.  But you can try this: download and install version 3 (http://www.thetournamentdirector.net/download.html), or version 2 (http://www.thetournamentdirector.net/downloadVersion2.html).  Either should install the newer control.  Then try 1.3.5 again.  If the control is already installed, it shouldn't try to install it again.  I honestly don't know if this will work.  Version 1.3.5 might specifically reference the older version.  So no promises.