Author Topic: Question On Version 3.1.1  (Read 759 times)

JimG

  • Newbie
  • *
  • Posts: 27
    • View Profile
Question On Version 3.1.1
« on: March 17, 2012, 08:38:11 AM »
I currently have TD 3.0 patch 14 and I noticed the message about the new version 3.1.1. Is it important to make the upgrade?  Other than making a backup, are there any other precautions to take before upgrading?

Thanks

TIMMER

  • Hero Member
  • *****
  • Posts: 555
    • View Profile
Re: Question On Version 3.1.1
« Reply #1 on: March 17, 2012, 11:23:07 AM »
On the Game tab, bottom left NEWS click change log, it will show you any chages or updates, if you need the update download it, to save a backup i dont unless its a new version, but i might be doing it wrong. ???

JimG

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Question On Version 3.1.1
« Reply #2 on: March 17, 2012, 05:36:52 PM »
Thanks...

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5379
    • View Profile
Re: Question On Version 3.1.1
« Reply #3 on: March 19, 2012, 11:25:17 AM »
A backup should suffice for upgrading.

What I typically put into a patch are fixes that need to go ASAP.  Any fix that goes into a patch will also be added to the next version of the product.

There are usually some additional items that go into an actual release.  But the only way to be sure is to check out the list of changes.  That can be pretty tedious, I understand, but for a release like 3.1.1 you'll find it pretty small.

I've also started enumerating which bugs were fixed in patches and which were fixed in the actual release.  So, for example, if you look in the version 3.1 change log, you'll see things like :

- (3.0): Error can occur when backing up or restoring data
- (3.0): Edit Sound dialog on Events tab errors when OK or Cancel button
  pressed (fixed in 3.0 patch 1)


The first item was a bug in version 3.0 that is fixed in version 3.1.  The second item is also a bug in 3.0 that was fixed in 3.1, but was also fixed for 3.0 in the first patch.  So you've already got the fix for the second item because you have version 3.0 patch level 14, but you don't have the fix for the first item (because it wasn't released in a patch).