Author Topic: 2.6 beta 5  (Read 28214 times)

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #45 on: May 15, 2011, 11:20:24 AM »
Your screenshot is of 2.5.12, not 2.6 beta 5.

That aside, the database format has changed in 2.6, so when you upgrade to 2.6, once you start 2.6 and make any change to anything in your database, it will be upgraded to the new format.  If you decide then to downgrade back to 2.5.12, the software won't understand the new database format, and you'll see this error.  If you really are trying to downgrade back to 2.5.12, you should restore the backup you made when you upgraded to 2.6.  You did create a backup, right?  :)

jodybingo

  • Hero Member
  • *****
  • Posts: 656
    • View Profile
    • Personal Web Site
Re: 2.6 beta 5
« Reply #46 on: May 15, 2011, 01:20:49 PM »
Clicked Merge All...Then Clicked on X to close window (did not accept suggestions), then this popped up

Object doesn't support property or method 'selectBlue' (PlayersTab, TournamentPage: 1)
 at openDialog(MergeGamePlayersDialog)
 at mergeGamePlayersDialog(Tournament)
 at PlayersTab.mergeGamePlayersDialog()

Browser: Microsoft Internet Explorer
Browser Beta: false
Browser Client Info Version: 7.0
Browser Code Name: Mozilla
Browser Decided Version: 9.0
Browser Detected Version: 9.0
Browser Language: en-US
Browser Minor Version: 0
Browser Version: 4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPNTDF; InfoPath.2; .NET4.0C)
Cookies Enabled: true
CPU Class: x86
Data Folder: C:\Users\Jody\Documents\The Tournament Director 2
Date: 2:17:28 pm 05/15/2011
DB File: \\bravoclock\c$\Users\Bravo\Documents\The Tournament Director 2\Data\db\td.db
DB Folder: \\bravoclock\c$\Users\Bravo\Documents\The Tournament Director 2\Data\db
Install Folder: C:\Program Files (x86)\The Tournament Director 2
Install Info: 812ea7628997fa05f99c83ad14fc031d
JScript Build: 16978
JScript Version: 5.8
License Info: Dy+cyISWZbUylpXcCSZe4a2HRfb9YFkPm6CN1qP+AYNvdn1Zsia3qT8JOti0JlJS6TILzed9ySbpMgvN533JJj23YJjj+2GWkjyk4s+oqwE=
Media Player Version: 12.0.7601.17514
Online: true
Platform: Win32
Preferences File: C:\Users\Jody\Documents\The Tournament Director 2\prefs.sav
Repo Config File: C:\Users\Jody\Documents\The Tournament Director 2\repo.sav
Repo Folder: \\bravoclock\c$\Users\Bravo\Documents\The Tournament Director 2\Data
Store Code: 12TcJXtmiYTlG99iw8i4XQ==
System Language: en-CA
TD Version: 2.6.b5
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPNTDF; InfoPath.2; .NET4.0C)
User Language: en-CA
Virtual Store Folder: C:\Users\Jody\AppData\Roaming\Local\VirtualStore\Program Files\The Tournament Director 2


Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #47 on: May 15, 2011, 10:48:40 PM »
Whoops, yep, typo.  bluR, not bluE.  Thanks!

macacan

  • Sr. Member
  • ****
  • Posts: 265
    • View Profile
    • Chorley Poker League
Re: 2.6 beta 5
« Reply #48 on: May 16, 2011, 11:42:53 AM »
Your screenshot is of 2.5.12, not 2.6 beta 5.

That aside, the database format has changed in 2.6, so when you upgrade to 2.6, once you start 2.6 and make any change to anything in your database, it will be upgraded to the new format.  If you decide then to downgrade back to 2.5.12, the software won't understand the new database format, and you'll see this error.  If you really are trying to downgrade back to 2.5.12, you should restore the backup you made when you upgraded to 2.6.  You did create a backup, right?  :)

Well you should know by now that I am a numpty.

I downloade the beta the other week, then thinking that I was downloading 2.6 beta 5, loaded 2.5.12.

What a numpty, all sorted now though.

 8) 8) 8) 8) 8) 8) 8) 8) 8) 8) 8) 8) 8) 8)

Seitz333

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Re: 2.6 beta 5
« Reply #49 on: May 16, 2011, 11:05:30 PM »
Just downloaded. Will run a test tourney tomorrow...

Thanks Corey.

Chuck

jodybingo

  • Hero Member
  • *****
  • Posts: 656
    • View Profile
    • Personal Web Site
Re: 2.6 beta 5
« Reply #50 on: May 25, 2011, 04:58:14 PM »
I created a new Stats profile and set the dates to include tournaments between May 15 and May 22 and when I refresh, it is giving me tournaments that were started after May 22. Did I miss a setting somewhere?

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #51 on: May 25, 2011, 08:39:46 PM »
Make sure you set the dates correctly (MM-DD-YYYY).  Don't know what else might be an issue.  I just tried it and it seemed to work fine for me.

whirlers

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
Re: 2.6 beta 5
« Reply #52 on: May 29, 2011, 07:18:29 AM »
I was just dabbling with the table collaspse order in 2.6 beta 5.
I have table 1 on the far right to collaspse last and the rest on the far left, whenever i move a table over to the far right and then move it up to change which table collaspse's last i get the error below. If i move table 1 down so the table below move up i don't get the error.....strange but thought i would post it.

'theLastControl' is undefined (TablesTab, TournamentPage: 594)
 at CollapseOrderDialog.moveUp(Boolean)
 at openDialog(CollapseOrderDialog)
 at collapseOrderDialog()

Browser: Microsoft Internet Explorer
Browser Beta: false
Browser Client Info Version: 7.0
Browser Code Name: Mozilla
Browser Decided Version: 8.0
Browser Detected Version: 8.0
Browser Language: en-US
Browser Minor Version: 0
Browser Version: 4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
Cookies Enabled: true
CPU Class: x86
Data Folder: C:\Users\Whirlers\Documents\The Tournament Director 2
Date: 1:13:22 pm 05/29/2011
DB File: C:\Users\Whirlers\Documents\The Tournament Director 2\Data\db\td.db
DB Folder: C:\Users\Whirlers\Documents\The Tournament Director 2\Data\db
Install Folder: C:\Program Files\The Tournament Director 2
Install Info: 812ea7628997fa05b7d037467c547148
JScript Build: 16385
JScript Version: 5.8
License Info: TBFJs98q5AZ8MeBelKMZtbNAW9SGjt0gu+8Eg5yiPhRZK7V4c7iJtYSnzB1iJISA7cx3wl52I1PpMgvN533JJjpT3kTbFsrRdBf18DaUc7U=
Media Player Version: 12.0.7600.16415
Online: true
Platform: Win32
Preferences File: C:\Users\Whirlers\Documents\The Tournament Director 2\prefs.sav
Repo Config File: C:\Users\Whirlers\Documents\The Tournament Director 2\repo.sav
Repo Folder: C:\Users\Whirlers\Documents\The Tournament Director 2\Data
Store Code: hJ1vaoN4YK8rG8336f+ZTayF7YfgpF5u
System Language: en-GB
TD Version: 2.6.b5
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
User Language: en-GB
Virtual Store Folder: C:\Users\Whirlers\AppData\Roaming\Local\VirtualStore\Program Files\The Tournament Director 2


Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #53 on: May 29, 2011, 03:16:32 PM »
There is a bug in the Collapse Tables dialog.  You cannot move the tables in the "Collapse these tables last" list up, or you'll see this error.  You can move them down, and you can move tables up and down in the "Collapse these tables first" dialog.

You can work around this by moving other tables down in the "Collapse these tables last" list.

jklaver

  • Newbie
  • *
  • Posts: 7
  • The Tournament Director deserves my respect!!
    • View Profile
Re: 2.6 beta 5
« Reply #54 on: July 28, 2011, 09:26:39 PM »
Will there be an official release for Beta 5? Let me know.
John "TrueNorthCanada"

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #55 on: July 29, 2011, 10:34:08 AM »
Absolutely there will be an official release.  And it is getting close.  I've pretty much shunned my social life (what little there still was) in order to finish it.

martin1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: 2.6 beta 5
« Reply #56 on: September 25, 2011, 07:07:03 AM »
New version is looking great! A couple of questions:

Will the Version Splash Screen messege pop up EVERY time we start the programme? Is there a way to disable it?
Will the database be compatable both ways with Version 2.5.12 / Version 2.5.11?

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5402
    • View Profile
Re: 2.6 beta 5
« Reply #57 on: September 25, 2011, 09:10:17 AM »
New version is looking great! A couple of questions:

Thank you.

Quote
Will the Version Splash Screen messege pop up EVERY time we start the programme? Is there a way to disable it?

No and no.  I realize this is an annoyance but it has been made necessary unfortunately.  I have changed the behavior so that it will open upon start up only the first time on any given day that you use the software, to reduce the annoyance.  There's no way to disable it ... that would defeat its purpose entirely.

Quote
Will the database be compatable both ways with Version 2.5.12 / Version 2.5.11?

File formats (including the database) are always forwards-compatible, but not backwards-compatible (maybe I have those terms reversed - I don't know).  That means that version 2.5.12, for example, should be able to load/read files created with any previous version.  But version 2.5.12 will not necessarily be able to load/read files created with future versions.

Magic_fubu

  • Hero Member
  • *****
  • Posts: 1035
    • View Profile
Re: 2.6 beta 5
« Reply #58 on: September 25, 2011, 11:46:10 AM »

File formats (including the database) are always forwards-compatible, but not backwards-compatible (maybe I have those terms reversed - I don't know).  That means that version 2.5.12, for example, should be able to load/read files created with any previous version.  But version 2.5.12 will not necessarily be able to load/read files created with future versions.


Yep... got them mixed up.... lol.... since the betas work with the older, it's backwards compatable, and if the older versions were to work with the betas, then it would be forward compatable.
My cowboys shot down your rockets
---
If you send a request to me please send that you got me from here w/your TD name to confirm. Thanks!

oddapokeren

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: 2.6 beta 5
« Reply #59 on: September 30, 2011, 02:45:37 PM »
Hi, is there a way that when the Print dialogue box appears that it prints automatically ? When I choose the autoprint with the keystrokes to send as default the Print dialogue box appears and I have to press the print button to have the thermal printer to print. The printer has been set as default printer in the Windows printers and faxes. :)

Thx

Best Regards

Erik