Author Topic: Background image in export template?  (Read 2079 times)

dniezby

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Background image in export template?
« on: August 06, 2009, 10:19:04 PM »
I'm guessing that not everything is parsed when exporting to HTML?

Code wise that is.

Here is my CSS for my logo that needs to be on the top left corner of my reports.  It works when I test a regular HTML file but it doesn't work when I export the report to HTML
Code: [Select]
<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=<charset>" />
    <title><eventname></title>
  </head>
<style type="text/css">
<!--

.infotable
{
font-family: Verdana, Helvetica, Arial, sans-serif;
font-size: 12pt;
width: 97%;
border: 1px solid;
}

.eventname
{
font-size: 14pt;
font-weight: bold;
font-family: Verdana, Helvetica, Arial, sans-serif;
}

.description
{
font-weight: bold;
}

.playersTable
{
border: 1px solid #000000;
padding: 4px;
font-family: arial;
font-size: 12pt;
width: 97%;
height: 200px;

}

.playersColumnHeader
{
font-weight: bold;
font-family: Verdana, Helvetica, Arial, sans-serif;
font-size:12pt;
text-align: center;}

.playersColumn
{

}

.odd
{
}

.even
{
background-color: #eeeeee;
}
.eaf_frame
{
 border: 4px #ff0000 double;
 cellpadding: 0;
 cellspacing: 0;
 width: 100%;
 height: 100%;
}
.logo{
background-image: url(./images/wpt.png);
position: static;
visibility: visible;
top: 15pt;
left: 15pt;
z-index: 1000;
background-repeat: no-repeat;
width:160px;
height: 75px;
background-attachment: relative;
background-position: 10px 10px;}

.address {
text-align: left;
font-family: Verdana, Helvetica, Arial, sans-serif;
font-size: 10pt;
vertical-align:top;}
-->
</style>
  <body>

<table class="eaf_frame" border="0" cellpadding="0" cellspacing="0">
<tbody>
<tr>
<td class="logo">&nbsp;<br>
</td>
<td class="address"><b>World Poker Tour Amateur Poker League Inc.</b>
<br>15 S. Colonial <br>
Eastborough, KS. 67901<br>
</td>
<td class="address">Phone: 123-456-7800<br>
Fax: <br>
Toll-Free Fax: <br>
</td>
<td><b>Sanction League Report</b><br>
</td>
</tr>
<tr>
<td colspan="4" rowspan="1" style="vertical-align: top;"><br />
<center>
<table class="infotable">
<tbody>
<tr>
<td style="vertical-align: top;"><eventname><br>
</td>
</tr>
<tr><playerRankingsColumns>
</tr>
</tbody>
</table>
</center>
<br>
<center><table summary="player ranks" class="playersTable">
<tr>
<td><playerRankingsRows></td>
</tr>
</table></center>
Insert signature info here.
</table>
</td>
</tr>
    </tbody>
</table>
<br>
</body>
</html>
« Last Edit: August 06, 2009, 10:24:51 PM by dniezby »

Corey Cooper

  • Administrator
  • Hero Member
  • *****
  • Posts: 5420
    • View Profile
Re: Background image in export template?
« Reply #1 on: August 07, 2009, 09:53:08 AM »
You lost me.  What should have happened?

dniezby

  • Jr. Member
  • **
  • Posts: 79
    • View Profile
Re: Background image in export template?
« Reply #2 on: August 07, 2009, 10:38:35 AM »
I figured it out.

I have our logo in the top left corner of this report.

When I was developing the report I was developing it in /templates  but when I was exporting the report I created a new directory /saves/exports

When I exported it, it wasn't able to find the logo because I'm a dingbat and didn't move the file to /saves/exports/images/

It works now. I just had to move any logos or images to the correct path.