The Tournament Director Forums

Main => Help Me => Topic started by: Silver Owl on November 10, 2012, 10:24:48 AM

Title: Sound problem
Post by: Silver Owl on November 10, 2012, 10:24:48 AM
I'm having a problem getting my sound files to play correctly

I have a sound file playing at the start of each round announcing the blinds with a break after round 4.
My problem is that the sound file for the round 4 blinds are playing at the start of round 4 like it should, but its also playing at the start of the break.
I can't figure out what I'm doing wrong.
I have a sound event setup for each round. Its as if TD is seeing the break as round 4 again.
Any help is appreciated. 
Title: Re: Sound problem
Post by: Magic_fubu on November 10, 2012, 11:24:26 AM
It sounds like you have the event set up for a round (isround && round = 4, or something like that). Since you want it to be a break, you would want it to be notisround, i believe.
Title: Re: Sound problem
Post by: Silver Owl on November 10, 2012, 11:37:46 AM
TD keeps the last round number for breaks. I was using roundNum=? and couldn't get it to work. I changed to level=? and its working.
I don't think I had this problem with earlier versions, but its working now.
Title: Re: Sound problem
Post by: Corey Cooper on November 10, 2012, 04:38:46 PM
If you have a break scheduled after round 4, then during that break it is still technically round 4 (because round 5 has not yet started).

A possibly better way to put it is that during the break after round 4 ends, the tournament is currently in a break but the round number is still 4.

If you've got an event that fires at the start of round 4 but don't want it to fire at the start of a break that happens to be directly after round 4, you would set the trigger to "A level start" and set the conditions to:

isRound and (roundNum = 4)

Without the isRound part, it will fire at the start of round 4 AND at the start of a break that is immediately after round 4.  isRound will be true during any round but false during a break.  This prevents it from firing during the break after round 4.
Title: Re: Sound problem
Post by: Silver Owl on November 10, 2012, 04:59:16 PM
Thanks Corey,
 I have had it setup correctly ( at least it was working ) for the last 4 years but the last couple ot games the sounds were getting messed up. I don't know what I changed but it works now.
BTW using level instead of roundNum seems to have solved my problem also.